10 вещей, которые вы должны знать о WordPress 2.1

Сегодня должна быть выпущена новая версия Wordpress 2.1. Aaron Brazell написал интересную заметку, чего следует ожидать пользователям Wodrress в новой версии. Предлагаю вам краткий вариант на русском:

  1. Автоматическое сохранение черновиков. 
    В Wordpress 2.1 появится функция автосохранения сообщений, когда вы пишите. Благодаря использованию AJAX, эта операция будет производиться без перезагрузки страницы. Для автосохранения необходимо, чтобы было указано название сообщения.
  2. Усовершенствованная загрузка и обработка картинок.
    Появится возможность редактирования сообщения после того, как оно загружено.
    Wordpress 2.1
  3. Устраняются переменные $tableposts, $tablecomments и другие.
    Вместо них нужно будет использовать другие переменные. Например, вместо $tableposts будет $wpdb->posts. Подробней об этом изменении.
  4. Совместимость плагинов.
    Из-за устранения поддержки переменных, как упомянуто выше, некоторые плагины могут перестать работать. Поэтому сейчас составляется список совместимых плагинов.
  5. Встроенная функциональность для миграции.
    Будет добавлена возможность миграции с одного блога Wordpress на другой блог Wordpress (и, как я понял, можно будет импортировать блог с Wordpress.com).
  6. Версия MySQL.
    MySQL версии 3.23 больше не поддерживается. Для работы будет нужна версия 4.0+.
  7. Новый интерфейс визуального редактора.
    В визуальном редакторе появятся табы для переключения с визуального режима на код и наоборот.

    Wordpress 2.1
  8. Единые категории для сообщений и ссылок.
  9. Приватность.
    В Wordpress 2.1 появится возможность блокировать блог от поисковиков.
  10. Nonces.
    Благодаря этой функции, Wordpress позволяет генерировать случайные пароли, а также многие другие вещи, которые могут повредить ваш блог. Так, благодаря nonces, каждый запрос соответствует определённому событию, который позволяет делать только одну вещь одному человеку в пределах админки (т.е. одобрять комментарии или удалять сообщения). По сути, это заменяет диалог «Вы уверены?». Подробнее о nonces.

Обратите внимание

При обновлении могут возникнуть серьёзные проблемы, если вы используете MySQL 3.34. А также, если установленные плагины используют указанные в пункте 3 переменные. Рекомендую уточнить установленную версию MySQL и взглянуть на список совместимых плагинов.

Удачного блогинга :)

Прокомментировать запись